lkml.org 
[lkml]   [2000]   [Mar]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: devfs + xinit Authentication error
Richard Gooch wrote:
>
> Matthew Vanecek writes:
> > Douglas Gilbert wrote:
> > >
> > > I'm trying to use devfs (with the default configuration of devfsd) on
> > > a slightly modified RH 6.0 i386 platform. When I call startx it fails
> > > with an authentication error in xinit. [Works with the classic /dev .]
> > > Any guidance?
> > >
> > > Doug Gilbert
> >
> >
> > I'm having the exact same problem, on 2.3.48. It complains that I might
> > not own the console. /dev/tty0 exists, and is a link to /dev/vc/0. The
> > permissions on it are a little weird:
> >
> > lr-xr-xr-x 1 root root 0 Feb 29 15:50 /dev/tty0 -> vc/0
>
> Nothing weird about it. Symlink permissions basically don't matter.


>
> > I've tried changing them with a PERMISSIONS string in devfsd.conf and
> > directly, but of course chmod does not work on links--only on the file
> > that the link points to. And evidently, X thinks that it cannot write
> > to tty0, because tty0 (and *all* the symlinks, every last one of them
> > under /dev) do not have the write bit set. Admittedly, this is not a
> > problem on such devices as /dev/cdrom, or other read-only media, but
> > when you have apps with the old names hard-coded (like X), and want to
> > make symlinks to satisfy those hard-codings, but the symlinks won't let
> > you make them lrwxrwxrwx, you can get rather frustrated.
> >
> > root@reliant:/dev$ ls -l tty0
> > lr-xr-xr-x 1 root root 0 Feb 29 15:50 tty0 -> vc/0
> > root@reliant:/dev$ rm -f tty0
> > root@reliant:/dev$ ls -l tty0
> > ls: tty0: No such file or directory
> > root@reliant:/dev$ ln -sf vc/0 tty0
> > root@reliant:/dev$ ls -l tty0
> > lr-xr-xr-x 1 root root 0 Feb 29 23:07 tty0 -> vc/0
> >
> > This would seem to be a fairly major failing in either devfs or
> > devfsd. Is it a known bug, or really a bug? How do we fix it? It
> > doesn't seem to be documented anywhere. I've tried playing with the
> > umask, and deleting/recreating symlinks, but nothing seems to work.
> > Is there some undocumented configuration option that I should know
> > about?
>
> The bug is in X. It should use stat(2) or access(2) and not lstat(2)
> to figure permissions. Assuming that's what X is doing. The bug isn't
> in devfs/devfsd.
>

Well, I'm not real sure *what* X is doing, but it evidently expects to
find the w bit set, regardless if it's a link or not. vc/* is of course
owned by the logged-in user, and set to rw-rw-rw-, so that's not a
problem. However, I think for the short term (at the very least on my
own box) it would be easier to adjust devfs to create symlinks as
lrwxrwxrwx (instead of lr-xr-xr-x). Where in the code would I look to
adjust that? Not looking to submit a patch--just want to get it to work
here, until everyone else decides to use good coding practices.

> > TIA for answers. devfs has gone through some extreme changes since
> > 2.2.x. Once upon a time, it was fairly effortless and bug-free, and
> > compiling the patch into the kernel was really all that was
> > required. Now, it seems needlessly complicated. For systems
> > developers, I guess that's not an issue--as they like to spend
> > extraordinary amounts of time in making a system work, as opposed to
> > the rest of us who just want to use the system.
>
> Blame Linus for the name changes. In time, he expects distributions to
> see the merit in the new names and move over to devfs wholesale.
>
> Regards,
>
> Richard....

Linus:
Can we have the old name system back? It was really easier to work
with, and to me it was just as expressive. Or how about this--let's
pick a naming convention and STICK WITH IT!! devfs is stable enough to
be in the stable thread (where's the guy that was backporting to 2.2.x?
I miss him!), and as such, it's naming convention needs to be solidified
and stabilized. I want the old names back (by default--not by devfsd),
but if that's not possible, how about some assurance that you're not
going to change the 'standards' again?
(Like he'll ever read this anyhow. Oh, well, that's MHO, anyhow).


--
Matthew Vanecek
Visit my Website at http://mysite.directlink.net/linuxguy
For answers type: perl -e 'print
$i=pack(c5,(41*2),sqrt(7056),(unpack(c,H)-2),oct(115),10);'
*****************************************************************
For 93 million miles, there is nothing between the sun and my shadow
except me. I'm always getting in the way of something...
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:56    [from the cache]
©2003-2011 Jasper Spaans