[lkml]   [2000]   [Feb]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectLFS (2+GB) problems.
    Just resently I have started messing with the lfs facilities now
    in place in the devel kernels and I have run into a few problems.

    A bit of info on what I had to do to get the stuff to work (not problems
    just general info)

    o Install new glibc 2.1.3 snapshot (previous versions didnt know of
    stat64 syscall?)
    o Rebuilt fileutils to try and fix a problem
    (see below it didnt fix anything unfortunately.)
    o I ran the try-lfs program to create a file it maxed out at 4TB.
    This seems ok?

    Here are my problems:

    o I can create files larger than 4GB BUT I cannot remove them cleanly.
    o On a reboot e2fsck truncates any file larger than 4GB to 4GB.

    I am not sure if these are userspace or kernel space problems... But I do know
    that I now have a fully LFS aware rm... (I recompiled fileutils.) and it still
    doesnt seem to work. However it definately looks like somewhere a 32Bit
    number is being coerced into a 64Bit one... esp since 4GB is exactly 2^32...

    Also... the first time I ran e2fsck it complained to me about having a large
    file on the FS... It said I needed to turn on some flag in the superblock
    (I cant remember the name) to enable LFS support... How do I turn it on
    if e2fsck didnt already? What is the flag named? Is there any real docs
    on how to set up LFS in linux? I cant seem to find any.

    Any help in this issue greatly appreciated!

    Mike Panetta

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 13:56    [W:0.045 / U:15.496 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site