[lkml]   [2000]   [Oct]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: Incorrect UDMA timing on VIA vt82c596b

    Ok, that means Andre's patch works. Congrats, Andre! Now, could you send
    me 'hdparm -i /dev/hdb' for the ZIP? It seems to be in SWDMA0 mode,
    which is interesting, because I thought it can't do that. You probably
    have some newer model.

    Do all your drives work correctly now?

    Thanks for your effort,

    On Tue, Oct 10, 2000 at 06:40:42AM -0500, Jordan wrote:
    > I am currently booted into a 2.4.0-test10-pre1 kernel with two
    > modifications, the VIA 3.6 drivers you have provided and the Patch from
    > Andre that you sent. My IBM is the primary master with the zip as its
    > slave and the Kenwood is the secondary master with the Plextor as its
    > slave. Here is my /proc/ide/via file:
    > ----------VIA BusMastering IDE Configuration----------------
    > Driver Version: 3.6
    > South Bridge: VIA vt82c596b (cf/cg)
    > Revision: ISA 0x23 IDE 0x10
    > BM-DMA base: 0xd000
    > PCI clock: 33MHz
    > Master Read Cycle IRDY: 0ws
    > Master Write Cycle IRDY: 0ws
    > BM IDE Status Register Read Retry: yes
    > Max DRDY Pulse Width: No limit
    > -----------------------Primary IDE-------Secondary IDE------
    > Read DMA FIFO flush: yes yes
    > End Sector FIFO flush: yes yes
    > Prefetch Buffer: yes yes
    > Post Write Buffer: yes yes
    > Enabled: yes yes
    > Simplex only: no no
    > -------------------drive0----drive1----drive2----drive3-----
    > Transfer Mode: UDMA DMA UDMA DMA
    > Address Setup: 30ns 60ns 30ns 30ns
    > Cmd Active: 90ns 90ns 90ns 90ns
    > Cmd Recovery: 90ns 90ns 30ns 30ns
    > Data Active: 90ns 240ns 90ns 90ns
    > Data Recovery: 30ns 240ns 30ns 30ns
    > Cycle Time: 30ns 480ns 60ns 120ns
    > Transfer Rate: 66.0MB/s 4.1MB/s 33.0MB/s 16.5MB/s
    > Here is the apporiate portion of /var/log/dmesg:
    > Uniform Multi-Platform E-IDE driver Revision: 6.31
    > ide: Assuming 33MHz system bus speed for PIO modes; override with
    > idebus=xx
    > VP_IDE: IDE controller on PCI bus 00 dev 39
    > VP_IDE: chipset revision 16
    > VP_IDE: VIA vt82c596b (cf/cg) IDE UDMA66 controller on pci0:7.1
    > ide0: BM-DMA at 0xd000-0xd007, BIOS settings: hda:DMA, hdb:pio
    > ide1: BM-DMA at 0xd008-0xd00f, BIOS settings: hdc:DMA, hdd:DMA
    > hda: IBM-DTLA-307075, ATA DISK drive
    > hdb: IOMEGA ZIP 250 ATAPI, ATAPI FLOPPY drive
    > hdc: KENWOOD CD-ROM UCR-421 V226G, ATAPI CDROM drive
    > hdd: PLEXTOR CD-R PX-W1210A, ATAPI CDROM drive
    > ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    > ide1 at 0x170-0x177,0x376 on irq 15
    > hda: 150136560 sectors (76870 MB) w/1916KiB Cache, CHS=9345/255/63, UDMA(66)
    > hdc: ATAPI 68X CD-ROM drive, 2048kB Cache, UDMA(33)
    > Uniform CD-ROM driver Revision: 3.11
    > hdb: set_drive_speed_status: status=0x51 { DriveReady SeekComplete Error }
    > hdb: set_drive_speed_status: error=0x04
    > hdb: 244736kB, 239/64/32 CHS, 4096 kBps, 512 sector size, 2941 rpm
    > Partition check:
    > hda: hda1 hda2 hda3 hda4 < hda5 hda6 hda7 hda8 hda9 hda10 hda11 >

    Vojtech Pavlik
    SuSE Labs
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 12:39    [W:0.028 / U:119.984 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site