lkml.org 
[lkml]   [2000]   [Jan]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRE: Hangs after "Loading" but before "Uncompressing"
On Tue, 25 Jan 2000, Markley, Todd wrote:

> Richard:
> I have already tried this, it also hangs before I get any
> "Uncompressing" message. I also tried using LOADLIN from a floppy, and
> I get the same thing. I can take these same boot disks to another
> computer and they boot fine. It never gets far enough to have a problem
> with mounting the root. It would seem to me that something is going
> wrong in arch/i386/boot/setup.S, but I don't know my way around this
> part of the software well enough to figure out what is going wrong.
> The kernel compile can't be broken because floppy will boot on other
> systems, including the system it was compiled on.
>

There isn't anything in setup.S that would run differently on a
'386 to a '686. The CPU-dependent stuff runs after everything is
uncompressed. That said, there is a loop in setup.S that I don't
like. At line 690, the label, a20_wait, 4 lines later a `je a20_wait`.

Comment that out with a '#' and see if it boots. This alias may remain
in the cache forever so it's not a good way to see if a20 is enabled.

Let me know if it 'fixes' the problem. If so, the person who rewrote
setup.S should find another way to check on a20.


Cheers,
Dick Johnson

Penguin : Linux version 2.3.39 on an i686 machine (800.63 BogoMips).


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:56    [from the cache]
©2003-2011 Jasper Spaans