lkml.org 
[lkml]   [1999]   [Aug]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject_Very_ strange network delay over dialup-ISDN in 2.2.11.
Hi out there!

I just experienced a very wierd network delay:
I use a ISDN dialup line to my university. Normally I do not run ping,
so this is - apart from a similar occurence with up to 20 sec lags in
2.2.10 - the first time I noticed this behaviour. But this time I wanted
to keep the connection established. So I fired up ping, and saw that it
reported a round-trip time of 1 second (1000 ms)! Usually it is
somewhere around 50 ms and under heavy load (ftp) it sometimes increases
to a few hundred ms, also up to one second but only for some few
packets.
Now the funny thing started, as I started an ftp session:
round-trip times dropped to around 100ms ?!
After the transfer was completed, I shut down the link and opened it
again. Ran ping, same result: 1000ms.
Then I ran a second ping, to another host on the same ethernet segment
in the university. It inherited the huge round-trip time, but the first
ping came down to around 100ms.
Curiosly I pinged another host, which is quite close (topologically) to
the dialin server. That ping was from the beginning <~ 100ms, the second
ping stayed at 1000ms and the first was reduced even further (60-90 ms).

Now this seems funny and strange to me and it could only be resolved by
shutting down the ISDN system (/sbin/init.d/i4l stop) and starting it
again.

Some more infos I can give:
- I switched off tcp_timestamping as it results in poor transfer network
performance (see article of me some days ago).
- due to our university's news server being so slow between 23:00 and
0:00 local time, the ISDN line timed out with a TCP connection to the
news server still open. So now there lurks a connection in FIN_WAIT IIRC
(it has apparently timed out now, as I took the ISDN subsystem down)
that cannot be completed due to differing assigned IP numbers on every
login.

I can provide tcpdumps (tcpdump -i ippp0 -n) of a normal session and the
weird one on request, but they are too big to be posted (14 and 27K,
resp.). cannot test pre-12's, because I first have to fix my raid
stuff to use new semantics.

Anyone got a clue?

Marc
--
Marc Mutz <Marc@Mutz.com> http://marc.mutz.com/
University of Bielefeld, Dep. of Mathematics / Dep. of Physics

PGP-keyID's: 0xd46ce9ab (RSA), 0x7ae55b9e (DSS/DH)


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:53    [from the cache]
©2003-2011 Jasper Spaans