lkml.org 
[lkml]   [1999]   [Jul]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectIP Aliasing in 2.2.x (bug?)
Guys,  I'm having the strangest problem over here with IP alaising.  I have tried the latest 2.2 kernels as well to blindly remedy the situation to no avail.  Things did work as they should with 2.0.34 for the longest time.  The problem is as follows:

This specific machine aliasing about a hundred ip address's (note: this is RedHat 6.0 w/the upgrades.redhat.com kernel, etc...). As far as the virtual interfaces are configured, this is done via linuxconf with apparently creates these two files ifcfg-eth0:0 and ifcfg-eth0:0 ... the files read as (just for reference):

<soren@s2>:/etc/sysconfig/network-scripts$ cat ifcfg-eth0:0
IPADDR="208.246.162.15"
NETMASK=255.255.255.0
<soren@s2>:/etc/sysconfig/network-scripts$ cat ifcfg-eth0:1
IPADDR="208.246.163.2-102"
NETMASK=255.255.255.0
<soren@s2>:/etc/sysconfig/network-scripts$

The main interface is:

<soren@s2>:/etc/sysconfig/network-scripts$ cat ifcfg-eth0
DEVICE=eth0
IPADDR=208.246.162.11
NETMASK=255.255.255.0
NETWORK=208.246.162.0
BROADCAST=208.246.162.255
ONBOOT=yes
<soren@s2>:/etc/sysconfig/network-scripts$

As far as information on the machine, it's all the same hardware as was running 2.0.34 successfully forever, 3com 509 or something using the 3c59x module...

Now, To the actual problem itself...which I feel is extremely strange:

eth0 and the ip's specified in the eth0:? files are all configured and display as follows with ifconfig:

the main interface (works perfectly:

<soren@s2>:~$ /sbin/ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:10:5A:D1:37:30
inet addr:208.246.162.11 Bcast:208.246.162.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3715021 errors:0 dropped:0 overruns:0 frame:0
TX packets:4215048 errors:0 dropped:0 overruns:0 carrier:2
collisions:48815 txqueuelen:100
Interrupt:10 Base address:0xdc80

<soren@s2>:~$

An example virtual interface entry (as configured by redhat's startup scripts or linuxconf or however it's done under redhat...):

<soren@s2>:~$ /sbin/ifconfig eth0:22
eth0:22 Link encap:Ethernet HWaddr 00:10:5A:D1:37:30
inet addr:208.246.163.23 Bcast:208.246.163.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:10 Base address:0xdc80

<soren@s2>:~$

All the other aliased entries look exactly the same...and they all have the same problem...

All the aliased ip's on the machine WORK...to an extent... they work like this... in all cases... and yes, i've eliminated running programs on the machine as far as sendmail/httpd/everything and the same thing still happens...

If you try to say, PING one of those aliased IP's on the machine from inside our outside the local network, it will not work... BUT, that is ONLY the case if you have not had communicate with the actual -real- interface.... i.e. accessed 's2' directly, instead of one of the aliased ip's configured there...
So basically, if you tried to communcate with one of those ip's-- you wouldn't be able to UNLESS say, i ping'd your host from 's2' ...follow what I'm saying guys?

It's sorta difficult to explain in a few words but i'm trying to explain it as thorough as possible.

This is a vital machine and the the aliasing it does (web site hosting...) is obviously extremely vital to it's purpose... I probably should've tested the needed things before the heavy upgrade on the machine but I have been running 2.2 at home ever since it was released with zero problems. So I figured it wouldn't be a big deal ;)

Anyways,

Any help/insight would be greatly appreciated...I'm not looking forward to having to completely redo the machine again downgrading things to 2.0.34 or something.

I did come across something on dejanews where it seemed like a guy had a similair problem, he received one response which was something to the effect of it just not working yet in 2.2 I'm hoping that was a joke or something ;)

Thanks and extreme gratitude,

Soren

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:53    [from the cache]
©2003-2011 Jasper Spaans