lkml.org 
[lkml]   [1999]   [May]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: sym/ncr53c8xx phase error still present in 2.2.7
On Tue, 4 May 1999, Rainer Clasen wrote:

>
> I see similar problems with an NCR810A and an IBM DDRS 4.3G. I've removed
> anything else from the bus, replaced all cables, switched to known good
> terminators, disabled sync tarbsfer, queueing, disconnect. No luck. I tried
> 2.0.35, 2.2.[67] - if available with the sym83c8xx driver, too.
>

I have same type of drive:

sym53c8xx: at PCI bus 0, device 9, function 0
sym53c8xx: setting PCI_COMMAND_PARITY...(fix-up)
sym53c8xx: 53c860 detected with Symbios NVRAM
sym53c860-0: rev=0x02, base=0xdf000000, io_port=0xb000, irq=12
sym53c860-0: Symbios format NVRAM, ID 7, Fast-20, Parity Checking
sym53c860-0: initial SCNTL3/DMODE/DCNTL/CTEST3/4/5 = (hex) 05/ce/a0/01/00/00
sym53c860-0: final SCNTL3/DMODE/DCNTL/CTEST3/4/5 = (hex) 05/ce/a0/00/08/00
sym53c860-0: resetting, command processing suspended for 2 seconds
sym53c860-0: restart (scsi reset).
scsi0 : sym53c8xx - version 1.3c
scsi : 1 host.
sym53c860-0: command processing resumed
Vendor: IBM Model: DDRS-34560 Rev: S92A
Type: Direct-Access ANSI SCSI revision: 02
Detected scsi disk sda at scsi0, channel 0, id 4, lun 0
sym53c860-0-<4,0>: tagged command queue depth set to 8
scsi : detected 1 SCSI disk total.
sym53c860-0-<4,*>: FAST-20 SCSI 20.0 MB/s (50 ns, offset 8)
SCSI device sda: hdwr sector= 512 bytes. Sectors= 8925000 [4357 MB] [4.4 GB]
>
> I tried to reproduce this with FreeBSD 2.2.6 and 3.0 - Problem disapeared.
> It ran my stress test for 5 hours. Linux ran only between 5 minutes up to 2
> hours stable.
>
> Somehow I don't think it's hardware-related.
>

I have no scsi problems or errors at all, apart from about 2hrs into my
monthly four hour backup of all the machines on my network I get errors
like:


Apr 3 15:42:57 shawc kernel: ncr53c860-0-<4,0>: phase change 2-3
6@0037ec45 resid=2.
Apr 3 15:42:57 shawc kernel: ncr53c860-0-<4,0>: phase change 2-7
10@0037ee45 resid=4.
Apr 3 15:42:57 shawc kernel: ncr53c860-0-<4,0>: phase change 2-7
10@0037e845 resid=4.
Apr 3 15:42:57 shawc kernel: ncr53c860-0-<4,0>: phase change 2-7
10@0037f045 resid=4.
Apr 3 15:50:10 shawc kernel: attempt to access beyond end of device
Apr 3 15:50:10 shawc kernel: 08:06: rw=0, want=713034562, limit=704907

etc. ( I don't have logs for latest incident as they were lost in the
crash)

This happens when it is reading from VFAT partition on the IBM disk to ide
tape. My latest suspect is vfat, but I just got the problem again with the
fat-patch-16 patch in.

I have also had it happen when reading SMBFS from the network to the ide
tape.

It works perfectly every time with kernel 2.0.36.

So maybe a strange interaction between the 2.2,x scsi driver and the IBM
disk? Or the ide tape driver fouling up the bus?


--
Shaw Carruthers - shaw@shawc.demon.co.uk
London SW14 7JW UK
This is not a sig( with homage to Magritte).



-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:51    [from the cache]
©2003-2011 Jasper Spaans