lkml.org 
[lkml]   [1999]   [Jan]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    Subjectparallel port stops functioning in pre5
    Just compiled 2.2.0pre5, Pentium II 400, with both parallel port and
    parallel printer support built into the kernel, not as modules. On boot,
    I get:

    request_module[parport_lowlevel]: Root fs not mounted
    lp: driver loaded but no devices found

    I am not subscribed to the linux-kernel mailing list, please CC me any
    replies. This is my first post here so I apologize for any mistakes I
    might've made as a newbie.
    I have not applied the pre5-ac1 patch because I do not know how my
    OSS/Opensound installation will react to that.


    here is the whole boot-up screen (dmesg):

    Linux version 2.2.0-pre5 (root@pinhead) (gcc version egcs-2.91.60
    19981201 (egcs-1.1.1 release)) #2 Thu Jan 7 19:37:51 EST 1999
    Detected 400920069 Hz processor.
    Console: colour dummy device 80x25
    Calibrating delay loop... 399.77 BogoMIPS
    Memory: 128144k/131072k available (708k kernel code, 408k reserved,
    1764k data, 48k init)
    CPU: Intel Pentium II (Deschutes) stepping 02
    Checking 386/387 coupling... OK, FPU using exception 16 error reporting.
    Checking 'hlt' instruction... OK.
    POSIX conformance testing by UNIFIX
    mtrr: v1.26 (19981001) Richard Gooch (rgooch@atnf.csiro.au)
    PCI: PCI BIOS revision 2.10 entry at 0xfdb91
    PCI: Using configuration type 1
    PCI: Probing PCI hardware
    PCI: Enabling I/O for device 00:3a
    Linux NET4.0 for Linux 2.2
    Based upon Swansea University Computer Society NET3.039
    NET4: Unix domain sockets 1.0 for Linux NET4.0.
    NET4: Linux TCP/IP 1.0 for NET4.0
    IP Protocols: ICMP, UDP, TCP
    Starting kswapd v 1.5
    vesafb: framebuffer at 0xe6000000, mapped to 0xc8800000, size 8192k
    vesafb: mode is 1024x768x8, linelength=1024, pages=8
    vesafb: protected mode interface info at c000:7780
    vesafb: pmi: set display start = c00c77cf, set palette = c00c77fa
    vesafb: pmi: ports = 3c0 3c4 3c5 3c7 3c8 3c9 3d4 3d5 3d6 3d7 3d8 3d9 3da
    vesafb: scrolling: ypan using protected mode interface,
    yres_virtual=8192
    Console: switching to colour frame buffer device 128x48
    fb0: VESA VGA frame buffer device
    Serial driver version 4.27 with no serial options enabled
    ttyS03 at 0x02e8 (irq = 3) is a 16550A
    pty: 256 Unix98 ptys configured
    request_module[parport_lowlevel]: Root fs not mounted
    lp: driver loaded but no devices found
    Real Time Clock Driver v1.09
    PIIX4: IDE controller on PCI bus 00 dev 39
    PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:DMA, hdd:pio
    hda: ST38641A, ATA DISK drive
    hdb: WDC AC34300L, ATA DISK drive
    hdc: TOSHIBA CD-ROM XM-6302B, ATAPI CDROM drive
    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    ide1 at 0x170-0x177,0x376 on irq 15
    hda: ST38641A, 8207MB w/128kB Cache, CHS=1046/255/63, UDMA
    hdb: WDC AC34300L, 4104MB w/256kB Cache, CHS=523/255/63, UDMA
    hdc: ATAPI 32X CDROM drive, 256kB Cache
    Uniform CDROM driver Revision: 2.51
    Partition check:
    hda:hda: set_multmode: status=0x51 { DriveReady SeekComplete Error }
    hda: set_multmode: error=0x04 { DriveStatusError }
    hda1 hda2 < hda5 hda6 hda7 hda8 >
    hdb: hdb1 hdb2 hdb3 hdb4
    VFS: Mounted root (ext2 filesystem) readonly.
    Freeing unused kernel memory: 48k freed

    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.rutgers.edu
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:49    [W:0.021 / U:0.224 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site