[lkml]   [1999]   [Jan]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: More ATAPI/IDE fun. (zip drive this time)
    Andre M. Hedrick wrote the following:
    > On Fri, 22 Jan 1999, CaT wrote:
    > > > As for your multi-mode errors, the original changes that I made around
    > > > 2.1.122 were stubbed out, but you can enable them easily.
    > > >
    > > > Apply this, "ide-", to give you the option of multi-mode config.
    > > >
    > > > The other option is to edit ./drivers/block/ide.h at line #34
    > > >
    > > > #define INITIAL_MULT_COUNT 0 /* off=0; on=2,4,8,16,32, etc.. */
    > > > #define INITIAL_MULT_COUNT 1 /* off=0; on=2,4,8,16,32, etc.. */
    > >
    > > Applied that too... (erm.. both of them)
    > I realy would like to know if both work individually.

    No worries. I'll try it with pre9 which I've just setup and all. One, then
    the other. should be easy enough.

    > The idea was to determine if changing the INITIAL_MULT_COUNT value to ONE
    > as a default option would fix the error without the need of the actual
    > patch. Since I am looking beyond the current state of distrutions,

    I think I just had a braindead moment and just shoved everything in there ;)

    > no one () will like to have to do double builds of bootdisks.
    > Much less the average JOE, newbie or enduser, will not want to have to
    > guess which to use.
    > I do not want this to look like a MicroSoft Win98 install that took
    > two-hours to press the enter key from rolling and laughing on the floor.
    > "Should your computer halt, please reset and continue with the install"
    > Mind you that anybody who did not roar aloud must not understand /dev/null.

    That was amusing. :)

    > > > Please let me know if it goes away with either or both of these options.
    > >
    > > Well, in my sheer desire to get it all right I applied all that was
    > > mentioned above and a patch that got rid of the assembly strstr(),
    > >
    > > all in all the results so far are:
    > >
    > > * multimode errors no longer reported (I did turn the config option on)
    > I really need to know if this is resolve if we change the value of
    > INITIAL_MULT_COUNT with the option off works.

    No worries. I'll see if I can do it with pre9. (or final as it wants to
    call itself :)

    > > * zip drive actually works now too. mounted and happy at this very
    > > moment.
    > The UGLY zip fix would work, regardless of the strstr() error.

    *nod* cool. ok. shove that in also if the problem presents itself
    again in pre9.

    CaT ( URL:

    There was farting in the air that night,
    It lit so bright,

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 13:49    [W:0.021 / U:174.328 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site