lkml.org 
[lkml]   [1998]   [Sep]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: Problems building linux-nfs-0.4.22 with 2.1.117ac3 (fwd)
    Well, I am still working on getting my knfsd to work correctly, but I am
    almost certain that it is something I am doing that is stupid. I am
    running linux-2.1.1120pre3 with knfsd-980830.tar.gz

    Here is some info from my system:

    [atlas] [/home/gwhalin] > ps xa | grep '\(rpc\|nfs\|portmap\)'
    209 ? S 0:00 rpc.kstatd
    221 ? S 0:00 rpc.kmountd
    228 ? SW 0:00 (nfsd)
    229 ? SW 0:00 (nfsd)
    232 ? SW 0:00 (rpciod)
    199 ? S 0:00 portmap
    [atlas] [/home/gwhalin] >

    [atlas] [/home/gwhalin] > lsmod
    Module Size Used by
    nfsd 145540 2 (autoclean)
    lockd 28052 1 (autoclean) [nfsd]
    sunrpc 49760 1 (autoclean) [nfsd lockd]
    3c59x 16156 1
    devpts 3140 1 (autoclean)
    [atlas] [/home/gwhalin] >

    [atlas] [/home/gwhalin] > rpcinfo -p
    program vers proto port
    100000 2 tcp 111 rpcbind
    100000 2 udp 111 rpcbind
    100024 1 udp 810 status
    100024 1 tcp 812 status
    100005 1 udp 821 mountd
    100005 1 tcp 823 mountd
    100005 2 udp 826 mountd
    100005 2 tcp 828 mountd
    100005 3 udp 831 mountd
    100005 3 tcp 833 mountd
    100003 2 udp 2049 nfs
    100003 2 tcp 2049 nfs
    100021 1 udp 1024 nlockmgr
    100021 3 udp 1024 nlockmgr
    100021 1 tcp 1024 nlockmgr
    100021 3 tcp 1024 nlockmgr
    [atlas] [/home/gwhalin] >

    [atlas] [/home/gwhalin] > kexportfs
    /home kitty.numerix.com
    [atlas] [/home/gwhalin] >

    And then on kitty (client)

    kitty[root]/home/gwhalin>mount -F nfs atlas:/home /mnt/test
    nfs mount: atlas: NFS service not responding
    nfs mount: retrying: /mnt/test
    nfs mount: atlas:: RPC: Rpcbind failure - RPC: Timed out
    NFS fsinfo failed for server atlas: error 1 (RPC: Can't encode arguments)
    nfs mount: mount: /mnt/test: I/O error
    nfs mount: giving up on: /mnt/test
    kitty[root]/home/gwhalin>


    As you can see, I am unable to mount the exported mount point from the
    client. Any thoughts?

    Thanks,
    Greg

    --------------------
    Greg Whalin
    gwhalin@numerix.com


    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.rutgers.edu
    Please read the FAQ at http://www.altern.org/andrebalsa/doc/lkml-faq.html

    \
     
     \ /
      Last update: 2005-03-22 13:44    [W:0.019 / U:33.396 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site