[lkml]   [1998]   [Aug]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: DEVFSv50 and /dev/fb? (or /dev/fb/? ???)
>Fine, you don't like the new naming scheme. That's why the old names
>are still there. If you are deeply wedded to the old names, you are
>welcome to them. I'm not *forcing* you to use the new naming
>scheme. Go ahead and use the old names.

Actually you are. This is like saying that the new C++ standard doesn't
force one to use new style casts and gratuitous templates. Sure the old
device name (old style casts) are still there, for now, but "depricated".
One may choose not to use them but everybody else will and consequently one
will eventually have to deal with them. And most new systems will use devfs
if it is part of the kernel simply because its the new thing. Everything
does not need a new naming sceme, change only what needs to be changed like

>> Richard, I for one would rather live with thousands and thousands of
>> inodes in /dev/ than live with the "ugly" naming scheme of dev_fs.
>How about /dev/sd{a,b,c...} entries only for the discs you have? You
>can have that right now with devfs.

/dev/sd{a,b,c,...} is definately cleaner and simplier than
/dev/dsk/c0t0u0d0s0 (or whatever?!?!?!?). And EIDE devices definately do
not need all this verbosity. How about changing over to a derivative of

>> I readily agree that directory searches of a large /dev are slow
>> but again I would rather live with a slow directory search than with
>> the "ugly" naming scheme of dev_fs.
>Again, just use the old names: I didn't take tham away.
>> We need to keep the "KISS" principle in mind. While the naming scheme
>> of dev_fs may be logical it is not simple.
>> /dev/sda, /dev/sda[1-15] is simple.
>And you can keep using it.

Probably not for long if devfs is added.

>> Richard, I have read your FAQ where the naming scheme for SCSI disks
>> is described and it screams "ugly".
>So ignore the new names and keep using the old names. Nothing in your
>message talks about devfs itself, you're only addressing the minor
>issue of naming, which is in fact not a problem.

I think the verbosely cryptic naming sceme of the current devfs is the only
real problem with it. My suggestion is to simplify the naming (keeping
backward compatability when possible).

> Regards,
> Richard....
>To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
>the body of a message to
>Please read the FAQ at

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:43    [W:0.047 / U:8.720 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site