lkml.org 
[lkml]   [1998]   [Jun]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: broken dependancies on alpha
Check to make sure you've got "-m21164a" set in your gcc specs file if
needed (I'm not sure when/if it is.), then reduce the CFLAGS to avoid
the ',', which confuses the dependency generator.

Quoting myself from a recent linux-alpha post:

> Date: Tue, 26 May 1998 14:48:00 -0700
> From: pw (Pete Wyckoff)
> Message-Id: <199805262148.OAA25261@dancer.ca.sandia.gov>
> To: linux-alpha@vger.rutgers.edu
> Subject: v2.1 pyxis 2ndary bus scan
...
> 1. Bash syntax ">&" incompatibility.
> 2. Presence of "," in "-Wa,-m21164a" destroys make dependcies, forcing
> a complete recompile every time.
>
...
> diff -urN linux-2.1.103-stock/arch/alpha/Makefile linux-2.1.103/arch/alpha/Makefile
> --- linux-2.1.103-stock/arch/alpha/Makefile Fri May 8 00:09:20 1998
> +++ linux-2.1.103/arch/alpha/Makefile Tue May 26 07:28:53 1998
> @@ -32,14 +32,14 @@
>
> # determine if we can use the BWX instructions with GAS
> $(shell rm -f ./GAS_VER)
> -$(shell $(AS) --version >& ./GAS_VER)
> +$(shell $(AS) --version 2>&1 > ./GAS_VER)
> OLD_GAS := $(shell if cat ./GAS_VER | grep 'version 2.7' > /dev/null; then echo yes; else echo no; fi)
> $(shell rm -f ./GAS_VER)
>
> ifneq ($(OLD_GAS),yes)
> # if PYXIS, then enable use of BWIO space
> ifeq ($(CONFIG_ALPHA_PYXIS),y)
> - CFLAGS := $(CFLAGS) -Wa,-m21164a -DBWX_USABLE -DBWIO_ENABLED
> + CFLAGS := $(CFLAGS) -DBWX_USABLE -DBWIO_ENABLED
> endif
> endif
-----------------------------------------------------
Pete Wyckoff | wyckoff@ca.sandia.gov
Sandia National Laboratories | 925 294 3503 (voice)
MS 9011, P.O. Box 969 | 925 294 1225 (fax)
Livermore, CA 94551 |

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu

\
 
 \ /
  Last update: 2005-03-22 13:42    [from the cache]
©2003-2011 Jasper Spaans