lkml.org 
[lkml]   [1998]   [Jun]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: ___ 2.0.34-pre11 (and pre16 too) /dev/mem broken???
On 3 Jun 1998, Andreas Jaeger wrote:

> >>>>> Alex Buell writes:
>
> Alex> Andrea Arcangeli wrote:
> >> >Even I have recompiled svgalib with gcc-2.8.1, it not works. ;-(
> >>
> >> Argggggggg, 2.0.x kernel ___________MUST____________ BE COMPILED WITH
> >> AND ONLY GCC-2.7.2.x!!!!!!!!!!
>
> Alex> development glibc v2.1 releases requires gcc-2.8.1. :o( I don't really
> Alex> want to have to upgrade to gcc-2.8.1 in order to use glibc v2.1, when I
> Alex> have a perfectly good v2.7.2.3 compiler! Whose *insert your favourite
> Alex> expletive here* decision was this, and why?
>
> Alex> Off topic I know, but I've had no real answers from reading the
> Alex> glibc-faq, glibc-howto et. even subscribed to the glibc-mailing.
>
> Alex> Cheers,
>
> You can use gcc 2.7.2 and egcs and gcc 2.8.1 together on the same
> system with simple command line switches (e.g. gcc -V gcc-2.7.2.3) or
> by installing them in separate paths (CC=/opt/egcs/bin/gcc works fine
> for me ;-).

Hi Andreas :)

There's an easier way. Edit gcc/Makefile.in and search for echo..
then change gcc to (eg) tgcc or egcc or whatever. The same can be
done in cp/Make-lang.in and f/Make-lang.in for c++ and fortran. The
only thing to watch out for is that gcc-2.7.x cannot be configured
to the same directory (i[456]86-blah) as any of the new breed.

Also, if you want to have a g++ that is using the 2.7.x lib/headers,
you need to install these into the configuration directory..
/usr/i486-blah/lib and include. Then, you can build either way. The
same holds for cross-compilers.

This info is intended for folks who may not know how to deal with
multiple devel systems.. not for your consumption Andreas :)

>
> Try to rebuild glibc 2.1 development releases with gcc 2.7.2.x (it's
> not hard to disable the configure tests) and run make check. You'll
> get so many errors that you don't want to use gcc 2.7.2.3. Using gcc
> 2.7.2.x would lead to lots of complaints that glibc is broken - but
> instead your compiler is broken.

This cannot be stressed enough. Same for the unadvisability of compiling
kernel-2.0.x with a new-breed compiler.. despite 'works for me' reports.

-Mike


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu

\
 
 \ /
  Last update: 2005-03-22 13:42    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site