lkml.org 
[lkml]   [1998]   [Jun]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Date
    SubjectRE: CDROM Oops patch: 1st cdu31a tests
    > Well, that's not really nice.  Something is going bad, but it may be
    > that the official driver as of 2.1.99 also has big problems - more to
    > come on this.
    >
    > Here are my 1st tests reports:
    >
    > [note that my drive is a cdu33a, ie. double speed version of cdu31a]
    >
    > * cd with only a FS
    >
    ># modprobe cdu31a cdu31a_port=0x340
    ># modprobe isofs
    ># mount /cdrom # fstab lists iso9660
    >
    > The drive's LED keeps blinking red/orange, the console is frozen (no console
    > switch, no console spawn, gpm does not respond to mouse moves) - eject
    > button is ignored even after reboot - syscall does not return ?
    >
    ># cdeject
    > =>OK
    >
    >
    > * pure audio cd
    >
    ># cdeject does not complete; sometimes prints a "cannot read TOC" (sic);
    > eject-button can either interrupt cdeject, with "cannot open /dec/cdrom"
    > (occured after such a message), or cause (after several minutes waiting and
    > no response) several "Aiee, killing interrupt handler" intermixed with
    > register dumps containing corrupted date (eg. CPU with a very "high"
    > negative ID on my monoprocessor)
    >
    >
    > * cd with 1 data track and several sound tracks
    >
    ># cdeject
    > =>OK like pure FS
    >
    ># mount
    > same symptoms as pure FS
    >
    >
    > NOTES
    >
    > * "eject" under cdctrl behaves like cdeject in all cases
    >
    > * some operations fail with "cannot open /dev/cdrom", and then all attemps
    > fail with the same message - the eject button is ignored even after reboot
    >
    > * I'll recompile with DEBUG and see if I can get more precise info
    >
    > * I've not yet tried to reproduce the old oops, given the number of
    > other problems
    >

    I´ve also had problems with the cdu31a driver. Playing of cd:s doesn´t work for
    example. But mounting works now...
    I´ve changed my Pas-16 card (the cd controller is on it) , to a ALS100 , but
    I´ll plug the Pas16 back in again , to test the new patch...

    /Kristoffer Brånemyr

    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.rutgers.edu

    \
     
     \ /
      Last update: 2005-03-22 13:43    [W:0.023 / U:30.644 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site