lkml.org 
[lkml]   [1998]   [May]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject2.0.34pre16 SCSI problem
Date
Hi Alan and all,

I installed pre16 on my server. During the nightly backup I got a
lot of SCSI timeouts and resets but the box recovered eventually.
I have never observed such problems with earlier kernel versions,
including pre15.

The next afternoon I copied a kernel tree when the problem occured
again. This time I was unable to stop it so I power cycled the box.
I rebooted into 2.0.33 and after the file system checks I made a
few tests with copying kernel trees. No problems.

Then I booted pre16 again and did the same tests there - no problems.
A few hours later I started stress testing the system with a copy/diff
script. It took about half an hour until the problem showed up again.
Another power cycle.

Back in 2.0.33 I'm currently running the same tests to see if it's
a pre16 or a hardware problem.

Here's the beginning of /var/log/kernel:

May 24 15:19:09 grumbeer kernel: ncr53c810-0: SCSI phase error fixup: CCB alread
y dequeued (0x00011020)
May 24 15:19:29 grumbeer kernel: scsi : aborting command due to timeout : pid 69
2714, scsi0, channel 0, id 4, lun 0 Write (6) 04 b2 b8 f4 00
May 24 15:19:29 grumbeer kernel: ncr53c8xx_abort: pid=692714 serial_number=69271
8 serial_number_at_timeout=692718

General information:
Chip NCR53C810, device id 0x1, revision id 0x2
IO port address 0xe800, IRQ number 15
Using memory mapped IO at virtual address 0x4805000
Synchronous period factor 25, max commands per lun 8
Profiling information:
num_trans = 92099
num_kbytes = 707872
num_disc = 75594
num_break = 3326
num_int = 3344
num_fly = 92079
ms_setup = 70880
ms_data = 440300
ms_disc = 1371370
ms_post = 7820

Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
Vendor: TOSHIBA Model: CD-ROM XM-3601TA Rev: 0265
Type: CD-ROM ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 01 Lun: 00
Vendor: HP Model: C2490A-300 Rev: 4140
Type: Direct-Access ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 02 Lun: 00
Vendor: IBM Model: DORS-32160 Rev: WA6A
Type: Direct-Access ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 04 Lun: 00
Vendor: FUJITSU Model: M1603S-512 Rev: 6C01
Type: Direct-Access ANSI SCSI revision: 02

It is the FUJITSU with which I'm doing these tests and which is causing
the problems.

Browsing through the pre16 patch, I see about one billion SCSI related
changes so I have no way of telling what could be wrong...

hjb
--
Veni, Vidi, VISA:
I came, I saw, I did a little shopping.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu

\
 
 \ /
  Last update: 2005-03-22 13:42    [from the cache]
©2003-2011 Jasper Spaans