[lkml]   [1998]   [May]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: pre-2.1.100-1: can't log in, ftpd trouble, and unresolved symbols
On Sun, 17 May 1998, Trevor Johnson wrote:

> I've seen the problem with 2.1.99, pre-2.1.100-1, and 2.1.102. On the
> system where I was running 2.1.99, the problem didn't appear right away:
> it only occurred after I had a mishap while trying to update libc, and
> copied some files from /lib on my home computer (the other afflicted
> system) to correct the troubles with the libraries. When I updated
> to version 1.9.8, the problem disappeared. Now the 2.1.101 kernel is
> running on that system, and the problem has not reappeared. On my home
> computer, I also updated to 1.9.8, yet when I boot the 2.1.102
> kernel, I consistently have the problem. I do not have it when booting
> 2.1.89.

I've gone up to 2.1.98 and had no problems, but 2.1.99 and up (so far
2.1.99, 2.1.100-pre1 and pre3, and 2.1.101) have all given me the same
problem. I've updated my libc and (to 5.4.44 and 1.9.8,
respectively). I have tried building with GCC 2.8.1 and
binutils-, EGCS 1.0.2-release and binutils, and GCC with binutils and It's definitely an -EPERM
error, but I don't know where it's coming from yet.

> Doing "su trevor" didn't work for me on either system. I'd be happy to
> try your test program.

Same here - the result of trying to su to a user is the same as if I try
to go through a login prompt. And all I had for a test prog was the

main () {
int err = setuid(501);
> My home computer has gcc 2.8.1; the other (based on Red Hat 4.8)
> has gcc Both systems are using glibc 2.0.5 and the shadow suite.
> The Red Hat one has PAM too, of course.

I am, as I mentioned, on libc5 (currently the latest version). I have the
shadow suite installed, but I tried with a non-shadow login binary and got
the same results.

> One other person who had similar problems found that he had changed the
> permissions on / to 700 or somesuch. They are set to 755 on both the
> systems where I've had the problem.

Checked that. I wish it were that easy. Got 755 permissions, but still no
go. Gonna check some more stuff out - put printk()s in every place in
namei.c, so that hopefully I'll be able to figure out where the problem's
starting. I'll let you know what happens.

Derrik Pates

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to

 \ /
  Last update: 2005-03-22 13:42    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean