lkml.org 
[lkml]   [1998]   [Apr]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: 2.1.94 breaks ALS-100 SB16-compatible soundcard
Date
> in both 2.0.xx and 2.1.xx kernels, but linux-2.1.94 incorrectly
> identifies the card as being ALS-007 based. Quake still runs,
> but produces no sound. (No errors in any logs.)

Well its close - its identifying it as an ALS card because it has the
original registers

> * A patch for a typo in drivers/sound/dmabuf.c

its not a typo, its the way Hannu formats his code.

> I'd be happy to run some tests so that we can work out the
> proper way of identifying the ALS-007 and ALS-100 chips.

It may not be that easy to arrange. I will add an als007 parameter
to the sb module for the moment.

> Audio devices:
> 0: Sound Blaster (ALS-007) (4.2) ; should be: Sound Blaster 16 (4.2)

Well should be Sound Blaster (ALS-100) ;)

Alan


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu

\
 
 \ /
  Last update: 2005-03-22 13:42    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site