[lkml]   [1998]   [Dec]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: ASUS CD ROM 340 & 2.1.129+ dont work but work fine with 2.0.35+
    Alan Cox wrote:
    > > I had installed dos drivers for asus (but works with all atapi drivers ??
    > > it worked with my old atapi goldstarcd driver and ibmcd.sys driver in dos )
    > >
    > > and from dos i did:
    > > dir d: ; this only spins drive ( drive d is cdrom )
    > > c:\linux\loadlin vmlinuz root=/dev/hda4 ro vga=3
    > >
    > > and it booted in linux-2.1.132 fine and it works great under linux
    > In other words the DOS driver contains some workarounds for the faults with
    > the drive. Given running that first then booting Linux works, it would be
    > a reasonable guess from your previous observations that this driver fakes a CD
    > change or similar to fix the drive problem.

    This is the second drive that has been reported to have this abnormal
    behavior. I'll be back in a couple of days and see if we can't get a
    decent workaround for this hardware bug.

    * Jens Axboe <>
    * Linux CD-ROM Maintainer
    * "The only thing that interferes with my
    * learning is my education." -- A. Einstein

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 13:46    [W:0.019 / U:4.700 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site