[lkml]   [1998]   [Nov]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectSlow tar ? (2.1.129pre1 and pre4)

    Anyone else seen this?

    I compiled up (from .126) to 2.1.129pre1 (and later pre4) today.
    I noticed that for some reason, tar was working very very slowly.

    Thought it might be some background or disconnected process eating
    up memory/CPU, but top and ps showed nothing. I even init 1'ed and
    rebooted...still just as slow.. It would unpack 3 files, then
    stop for 7 or 8 seconds, three more...etc.

    It did this with every .tar.gz or bz2 I tried. I noted that
    both bzip2 and gzip worked perfectly, at full speed. Also
    I noticed that:

    bzip2 <file.tar.bz2> | cpio -ivud

    also worked at full speed. But:

    bzip2 <file.tar.bz2> | tar xvf -

    was as slow as tar Ixvf.

    Is this the scheduling problem that's been mentioned? Or is
    this something else. I havent change anything in my setup

    Sysinfo: Pentium 100; 16 Mb RAM ; glibc-2.0.7pre ;
    binutils; linux 2.1.129pre4

    Not complaining, just reporting :)

    Mark Orr

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 13:45    [W:0.028 / U:59.752 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site