lkml.org 
[lkml]   [1998]   [Nov]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: 2.1.128 Lock
Date
Simon Kirby enscribed thusly:
> A very similar thing happened to me, running stock 2.1.128. I was
> compiling Mozilla when "make" seemed to suddenly hang and do nothing...I
> tried to spawn a new rxvt to login to see what was happening, and it
> didn't pop up. I tried a few more times and nothing came up. I switched
> to console where I had an irc session running...I could still type and
> everything seemed to be okay, but when I tried to login to a console it
> took about 10 seconds before spitting out the "uptime" and then another 10
> seconds or so before giving me a prompt. During this time the disk was
> almost unused. This looks like exactly what happened with 2.1.127ac1 when
> I put it on the mail server machine after 10 minutes of uptime (heavy
> load). The number of new running processes kept rising and rising (POP3
> logins), and new processes seemed "blocked" (although nothing was shown as
> blocked in "vmstat" which was running at the time). I rebooted the
> mail server because it needed to be up _asap_, but my machine at home here
> which just the problem seemed to fix itself after about 30 seconds.

A number of us are experiencing similar problems. One burning
question I have for everyone who has experienced this... Was the kernel
built with SMP disabled? There are at least three other threads relating
to this problem. So far, everyone who has gotten back to me claims that
they built with SMP disabled. If anyone is experiencing this with SMP
enabled, even on a uniprocessor box, that would disprove the theory.
I would also like others who are experiencing this with SMP disabled to
rebuild with SMP enabled and try again...

> Machine has 128MB SDRAM, K6 233, ASUS TX97 board. Compiled with GCC
> 2.7.2.3. 3 EIDE drives, but the mail server I described earlier had a 5
> SCSI drives.

> Simon-
>
> | Simon Kirby | Systems Administration |
> | mailto:sim@netnation.com | NetNation Communications |
> | http://www.netnation.com/ | Tech: (604) 684-6892 |
> ---
> On Fri, 13 Nov 1998, Jeremy Katz wrote:
>
> > I've been running 2.1.128 since last night; uptime of around 23 hours or
> > so. I then experienced a lock of some sort. It occurred while I was
> > running configure for latest CVS of achtung in an Eterm while playing an
> > mp3 in replay. The mp3 continued to play until the end of the song when
> > it did not advance to the next one. I could switch vc's and type username
> > and password but bash would not start. Since I have sysrq compiled in, I
> > killed all processes running on tty7 (X) and that worked, but I was still
> > unable to log in at a console prompt. Then, the next mp3 in the queue
> > began to play; still unable to log in or do anything else, I proceeded to
> > sync,unmount, and reboot. Any ideas? I do have a process list (but not
> > with me) of what was running as well as the output of alt-sysrq-t if
> > needed.
> >
> > Please reply back to me directly as well since I am not subscribed to l-k
> > with this address.
> >
> > Thanks,
> >
> > =-=--=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
> > Jeremy Katz | linuxpower.org -- Helping Users Harness
> > Admin, NCSSM Unix Network | the Power of Linux
> > katzj@ncssm-server.ncssm.edu | http://linuxpower.org
> > katzj@iname.com | unknwn@linuxpower.org
> > "Microsoft is to software what McDonalds is to gourmet cooking"
> > -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
> >
> >
> > -
> > To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> > the body of a message to majordomo@vger.rutgers.edu
> > Please read the FAQ at http://www.tux.org/lkml/
> >
>
>
>
> -
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majordomo@vger.rutgers.edu
> Please read the FAQ at http://www.tux.org/lkml/
>


--
Michael H. Warfield | (770) 985-6132 | mhw@WittsEnd.com
(The Mad Wizard) | (770) 925-8248 | http://www.wittsend.com/mhw/
NIC whois: MHW9 | An optimist believes we live in the best of all
PGP Key: 0xDF1DD471 | possible worlds. A pessimist is sure of it!
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:45    [W:0.095 / U:0.888 seconds]
©2003-2014 Jasper Spaans. Advertise on this site