lkml.org 
[lkml]   [1998]   [Nov]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Date
    SubjectUnixPTY: running problems?
    Hi kernel-programmers!

    I'm now using Linux for about one and a half years. Up to now, I was always
    able to solve my problems on my own, but with this problem, I currently have, I
    can not cope with.
    I'm using the experimental version of the kernel [currently it is 2.1.125].
    Some time before I used 2.1.110 (around this kernel). In this there was no
    Unix98 support. When I updated to 2.1.125 I enabled the new Unix98-PTY-support
    without really knowing what it means. To my shame I must confess that I didn't
    read the manuals carefully enough so that I could understand what I'm enabling
    there. Well - obviously I enabled it, but I didn't update my libraries etc.
    The thing went as it must go: Almost no connection was possible via the
    network. Not realizing this problem (I did not often use the TCP/IP), I worked
    on and on, but some time later I reread the Documentation/Changes file and
    there suddently I realized what's going on. Not wanting to update my libraries
    I recompiled my kernel disabled devpts and unix98. But this had not had the
    wished result: Still any telnet session leads to an "Connection refused" with
    the error message "telnetd: All network ports in use". lpd and some other
    programs are having problems, too, mentioning the same error messages.
    Reading the documentation again, I found out that this problem was already
    discussed. So I enabled Unix98 again, started devpts and doing everything that
    is descibed in the Documentation/Changes. But this did not have any success
    either.
    So I dediced some time to the update of my libraries, too. There I experienced
    another problems so that I was not able to update the library to glibc6.

    So far I tried it on my own. But now, it seems to me that I'm not able to get
    my Linux server running again. But there's a funny aspect, too: in my near
    there's another Linux server running 2.1.125 too without Unix98. There is no
    problem at all! Everything works good and telnet is running fine.

    As I do not need the huge amount of 256 clients (on rush hours I have 2 or 3
    clients logged in that machine), it would be the best that the old system of
    pty's would run again.

    Did anybody have this or a related problem, too? Any suggestions/hints?

    If my mail is offtopic, can anyone tell me a mailinglist where this issue is
    related?

    Thanks for your help!


    Magu
    Nico

    EMail: schmoigl@rumms.uni-mannheim.de
    PGPkey: http://193.197.92.32/pgpkeys/eagle.asc
    Fingerprint: 5DDB 09E4 3FF3 CD09 7559 1117 9C03 46E3 38FC 9E03

    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.rutgers.edu
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:45    [W:0.021 / U:29.424 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site