lkml.org 
[lkml]   [1998]   [Oct]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Date
    Subject2.1.125 : request_module unresolved
    Hi,

    have got a principally RedHat 5 machine - (2x)P2-300, 128Mb RAM, ASUS P2B m/b.
    I've tried to follow all required upgrades recommended for 2.1 series kernels,
    and had a go at using 2.1.125. Some of the principal RPM's I'm now using are ...

    binutils-2.9.1.0.4-2
    gcc-2.7.2.3-8
    glibc-2.0.7-19
    glibc-devel-2.0.7-19
    libg++-2.7.2.8-6
    ld.so-1.9.5-5
    ldconfig-1.9.5-2
    modutils-2.1.85-4
    mount-2.7l-3
    net-tools-1.33-4 (couldn't find a later RPM)
    ppp-2.3.3-4
    procps-1.2.7-5
    procinfo-13-1

    Everything works fine, including recognising and using both processors, *except*
    for the loading of the sound and ppp modules. Basically modules are loading,
    except for the ones that require another modules to be loaded - hence ppp and
    sound. For example

    root@beast.16> insmod ppp.o
    ppp.o: unresolved symbol slhc_init_Rsmp_1ca65fca
    ppp.o: unresolved symbol slhc_compress_Rsmp_cfd3a418
    ppp.o: unresolved symbol slhc_free_Rsmp_b99033d9
    ppp.o: unresolved symbol slhc_toss_Rsmp_a152cec0
    ppp.o: unresolved symbol request_module
    ppp.o: unresolved symbol slhc_remember_Rsmp_07972313
    ppp.o: unresolved symbol slhc_uncompress_Rsmp_3bb36b01
    root@beast.17> insmod slhc.o
    root@beast.18> insmod ppp.o
    ppp.o: unresolved symbol request_module
    root@beast.19> ksyms -a | grep request
    c011a61c request_module_R__ver_request_module
    c01c7be8 wait_for_request_Rsmp_38adc092
    c0173654 make_request_Rsmp_d2b2857c
    c010a3c8 request_irq_Rsmp_0c60f2e0
    c0112da8 request_dma_Rsmp_43435480
    c0118c24 request_region_Rsmp_6d32b2d7
    c01c7be4 io_request_lock_Rsmp_08c39da6
    c0174194 end_that_request_first_Rsmp_c408142d
    c017424c end_that_request_last_Rsmp_57d6162d
    c0175960 do_ide0_request_Rsmp_9e250d18
    c0175988 do_ide1_request_Rsmp_49c78d40
    c01759b0 do_ide2_request_Rsmp_ea910be9
    c01759d8 do_ide3_request_Rsmp_3d738bb1
    c0175a00 do_ide4_request_Rsmp_774d00fa
    c0175a28 do_ide5_request_Rsmp_a0af80a2
    c0174670 ide_end_request_Rsmp_0ab78cf5

    I've read about kmod replacing kerneld and I actually have kerneld running at
    boot since it is in my startup for by 2.0.33 kernel, but I get the same after
    turning it off. Have searched some of the kernel mailing lists and the FAQ and
    could find nothing in there relating to this - so I've obviously omitted
    something important (!). Attached below is my kernel config setting
    -----------------------------------------------------------------------
    #
    # Automatically generated make config: don't edit
    #

    #
    # Code maturity level options
    #
    CONFIG_EXPERIMENTAL=y

    #
    # Processor type and features
    #
    # CONFIG_M386 is not set
    # CONFIG_M486 is not set
    # CONFIG_M586 is not set
    CONFIG_M686=y
    # CONFIG_MATH_EMULATION is not set
    # CONFIG_MTRR is not set

    #
    # Loadable module support
    #
    CONFIG_MODULES=y
    CONFIG_MODVERSIONS=y
    CONFIG_KMOD=y

    #
    # General setup
    #
    CONFIG_NET=y
    CONFIG_PCI=y
    CONFIG_PCI_BIOS=y
    # CONFIG_PCI_DIRECT is not set
    # CONFIG_PCI_QUIRKS is not set
    # CONFIG_PCI_OLD_PROC is not set
    # CONFIG_MCA is not set
    CONFIG_SYSVIPC=y
    # CONFIG_BSD_PROCESS_ACCT is not set
    CONFIG_SYSCTL=y
    CONFIG_BINFMT_AOUT=y
    CONFIG_BINFMT_ELF=y
    CONFIG_BINFMT_MISC=m
    # CONFIG_BINFMT_JAVA is not set
    CONFIG_PARPORT=m
    CONFIG_PARPORT_PC=m
    # CONFIG_PARPORT_OTHER is not set
    CONFIG_APM=y
    # CONFIG_APM_IGNORE_USER_SUSPEND is not set
    # CONFIG_APM_DO_ENABLE is not set
    # CONFIG_APM_CPU_IDLE is not set
    # CONFIG_APM_DISPLAY_BLANK is not set
    CONFIG_APM_POWER_OFF=y
    # CONFIG_APM_IGNORE_MULTIPLE_SUSPEND is not set

    #
    # Plug and Play support
    #
    # CONFIG_PNP is not set

    #
    # Block devices
    #
    CONFIG_BLK_DEV_FD=y
    CONFIG_BLK_DEV_IDE=y

    #
    # Please see Documentation/ide.txt for help/info on IDE drives
    #
    # CONFIG_BLK_DEV_HD_IDE is not set
    CONFIG_BLK_DEV_IDEDISK=y
    CONFIG_BLK_DEV_IDECD=m
    # CONFIG_BLK_DEV_IDETAPE is not set
    CONFIG_BLK_DEV_IDEFLOPPY=m
    # CONFIG_BLK_DEV_IDESCSI is not set
    # CONFIG_BLK_DEV_CMD640 is not set
    # CONFIG_BLK_DEV_RZ1000 is not set
    CONFIG_BLK_DEV_IDEPCI=y
    CONFIG_BLK_DEV_IDEDMA=y
    # CONFIG_BLK_DEV_OFFBOARD is not set
    # CONFIG_IDEDMA_AUTO is not set
    # CONFIG_BLK_DEV_OPTI621 is not set
    # CONFIG_BLK_DEV_TRM290 is not set
    # CONFIG_BLK_DEV_NS87415 is not set
    # CONFIG_BLK_DEV_VIA82C586 is not set
    # CONFIG_IDE_CHIPSETS is not set

    #
    # Additional Block Devices
    #
    # CONFIG_BLK_DEV_LOOP is not set
    # CONFIG_BLK_DEV_NBD is not set
    # CONFIG_BLK_DEV_MD is not set
    # CONFIG_BLK_DEV_RAM is not set
    # CONFIG_BLK_DEV_XD is not set
    CONFIG_PARIDE_PARPORT=m
    # CONFIG_PARIDE is not set
    # CONFIG_BLK_DEV_HD is not set

    #
    # Networking options
    #
    CONFIG_PACKET=y
    # CONFIG_NETLINK is not set
    CONFIG_FIREWALL=y
    CONFIG_NET_ALIAS=y
    # CONFIG_FILTER is not set
    CONFIG_UNIX=m
    CONFIG_INET=y
    CONFIG_IP_MULTICAST=y
    # CONFIG_IP_ADVANCED_ROUTER is not set
    # CONFIG_IP_PNP is not set
    CONFIG_IP_FIREWALL=y
    CONFIG_IP_TRANSPARENT_PROXY=y
    CONFIG_IP_ALWAYS_DEFRAG=y
    CONFIG_IP_MASQUERADE=y

    #
    # Protocol-specific masquerading support will be built as modules.
    #
    CONFIG_IP_MASQUERADE_ICMP=y

    #
    # Protocol-specific masquerading support will be built as modules.
    #
    # CONFIG_IP_MASQUERADE_MOD is not set
    # CONFIG_IP_ROUTER is not set
    CONFIG_NET_IPIP=m
    # CONFIG_NET_IPGRE is not set
    # CONFIG_IP_MROUTE is not set
    # CONFIG_IP_ALIAS is not set
    CONFIG_SYN_COOKIES=y

    #
    # (it is safe to leave these untouched)
    #
    # CONFIG_INET_RARP is not set
    CONFIG_IP_NOSR=y
    # CONFIG_SKB_LARGE is not set
    # CONFIG_IPV6 is not set

    #
    #
    #
    # CONFIG_IPX is not set
    # CONFIG_ATALK is not set
    # CONFIG_X25 is not set
    # CONFIG_LAPB is not set
    # CONFIG_BRIDGE is not set
    # CONFIG_LLC is not set
    # CONFIG_ECONET is not set
    # CONFIG_WAN_ROUTER is not set
    # CONFIG_NET_FASTROUTE is not set
    # CONFIG_NET_HW_FLOWCONTROL is not set
    # CONFIG_CPU_IS_SLOW is not set
    # CONFIG_NET_SCHED is not set

    #
    # SCSI support
    #
    # CONFIG_SCSI is not set
    # CONFIG_SCSI_G_NCR5380_PORT is not set
    # CONFIG_SCSI_G_NCR5380_MEM is not set

    #
    # Network device support
    #
    CONFIG_NETDEVICES=y
    # CONFIG_ARCNET is not set
    CONFIG_DUMMY=y
    # CONFIG_EQUALIZER is not set
    CONFIG_NET_ETHERNET=y
    # CONFIG_NET_VENDOR_3COM is not set
    # CONFIG_LANCE is not set
    # CONFIG_NET_VENDOR_SMC is not set
    # CONFIG_NET_VENDOR_RACAL is not set
    # CONFIG_RTL8139 is not set
    # CONFIG_YELLOWFIN is not set
    # CONFIG_NET_ISA is not set
    CONFIG_NET_EISA=y
    # CONFIG_PCNET32 is not set
    # CONFIG_AC3200 is not set
    # CONFIG_APRICOT is not set
    # CONFIG_CS89x0 is not set
    # CONFIG_DE4X5 is not set
    CONFIG_DEC_ELCP=y
    # CONFIG_DGRS is not set
    # CONFIG_EEXPRESS_PRO100 is not set
    # CONFIG_LNE390 is not set
    # CONFIG_NE3210 is not set
    # CONFIG_NE2K_PCI is not set
    # CONFIG_TLAN is not set
    # CONFIG_VIA_RHINE is not set
    # CONFIG_ES3210 is not set
    # CONFIG_EPIC100 is not set
    # CONFIG_ZNET is not set
    # CONFIG_NET_POCKET is not set
    # CONFIG_FDDI is not set
    # CONFIG_HIPPI is not set
    # CONFIG_DLCI is not set
    CONFIG_PLIP=m
    CONFIG_PPP=m

    #
    # CCP compressors for PPP are only built as modules.
    #
    CONFIG_SLIP=m
    CONFIG_SLIP_COMPRESSED=y
    CONFIG_SLIP_SMART=y
    # CONFIG_SLIP_MODE_SLIP6 is not set
    # CONFIG_NET_RADIO is not set
    # CONFIG_TR is not set
    # CONFIG_SHAPER is not set

    #
    # Amateur Radio support
    #
    # CONFIG_HAMRADIO is not set

    #
    # ISDN subsystem
    #
    # CONFIG_ISDN is not set

    #
    # CD-ROM drivers (not for SCSI or IDE/ATAPI drives)
    #
    # CONFIG_CD_NO_IDESCSI is not set

    #
    # Character devices
    #
    CONFIG_VT=y
    CONFIG_VT_CONSOLE=y
    CONFIG_SERIAL=y
    # CONFIG_SERIAL_CONSOLE is not set
    # CONFIG_SERIAL_EXTENDED is not set
    # CONFIG_SERIAL_NONSTANDARD is not set
    # CONFIG_UNIX98_PTYS is not set
    CONFIG_PRINTER=m
    # CONFIG_PRINTER_READBACK is not set
    CONFIG_MOUSE=y
    # CONFIG_ATIXL_BUSMOUSE is not set
    # CONFIG_BUSMOUSE is not set
    # CONFIG_MS_BUSMOUSE is not set
    CONFIG_PSMOUSE=y
    # CONFIG_82C710_MOUSE is not set
    # CONFIG_PC110_PAD is not set
    # CONFIG_QIC02_TAPE is not set
    # CONFIG_WATCHDOG is not set
    CONFIG_RTC=y
    # CONFIG_VIDEO_DEV is not set
    # CONFIG_NVRAM is not set
    # CONFIG_JOYSTICK is not set

    #
    # Ftape, the floppy tape device driver
    #
    # CONFIG_FTAPE is not set
    # CONFIG_FT_NORMAL_DEBUG is not set
    # CONFIG_FT_FULL_DEBUG is not set
    # CONFIG_FT_NO_TRACE is not set
    # CONFIG_FT_NO_TRACE_AT_ALL is not set
    # CONFIG_FT_STD_FDC is not set
    # CONFIG_FT_MACH2 is not set
    # CONFIG_FT_PROBE_FC10 is not set
    # CONFIG_FT_ALT_FDC is not set

    #
    # Filesystems
    #
    CONFIG_QUOTA=y
    CONFIG_MINIX_FS=m
    CONFIG_EXT2_FS=y
    CONFIG_ISO9660_FS=y
    # CONFIG_JOLIET is not set
    CONFIG_FAT_FS=m
    CONFIG_MSDOS_FS=m
    # CONFIG_UMSDOS_FS is not set
    CONFIG_VFAT_FS=m
    CONFIG_PROC_FS=y
    CONFIG_NFS_FS=m
    # CONFIG_NFSD is not set
    CONFIG_SUNRPC=m
    CONFIG_LOCKD=m
    # CONFIG_CODA_FS is not set
    # CONFIG_SMB_FS is not set
    # CONFIG_HPFS_FS is not set
    # CONFIG_NTFS_FS is not set
    # CONFIG_SYSV_FS is not set
    # CONFIG_AFFS_FS is not set
    # CONFIG_HFS_FS is not set
    # CONFIG_ROMFS_FS is not set
    CONFIG_AUTOFS_FS=m
    # CONFIG_UFS_FS is not set
    # CONFIG_BSD_DISKLABEL is not set
    # CONFIG_SMD_DISKLABEL is not set
    # CONFIG_SOLARIS_X86_PARTITION is not set
    # CONFIG_ADFS_FS is not set
    # CONFIG_QNX4FS_FS is not set
    # CONFIG_MAC_PARTITION is not set
    CONFIG_NLS=y

    #
    # Native Language Support
    #
    # CONFIG_NLS_CODEPAGE_437 is not set
    # CONFIG_NLS_CODEPAGE_737 is not set
    # CONFIG_NLS_CODEPAGE_775 is not set
    # CONFIG_NLS_CODEPAGE_850 is not set
    # CONFIG_NLS_CODEPAGE_852 is not set
    # CONFIG_NLS_CODEPAGE_855 is not set
    # CONFIG_NLS_CODEPAGE_857 is not set
    # CONFIG_NLS_CODEPAGE_860 is not set
    # CONFIG_NLS_CODEPAGE_861 is not set
    # CONFIG_NLS_CODEPAGE_862 is not set
    # CONFIG_NLS_CODEPAGE_863 is not set
    # CONFIG_NLS_CODEPAGE_864 is not set
    # CONFIG_NLS_CODEPAGE_865 is not set
    # CONFIG_NLS_CODEPAGE_866 is not set
    # CONFIG_NLS_CODEPAGE_869 is not set
    # CONFIG_NLS_CODEPAGE_874 is not set
    # CONFIG_NLS_ISO8859_1 is not set
    # CONFIG_NLS_ISO8859_2 is not set
    # CONFIG_NLS_ISO8859_3 is not set
    # CONFIG_NLS_ISO8859_4 is not set
    # CONFIG_NLS_ISO8859_5 is not set
    # CONFIG_NLS_ISO8859_6 is not set
    # CONFIG_NLS_ISO8859_7 is not set
    # CONFIG_NLS_ISO8859_8 is not set
    # CONFIG_NLS_ISO8859_9 is not set
    # CONFIG_NLS_KOI8_R is not set

    #
    # Console drivers
    #
    CONFIG_VGA_CONSOLE=y
    # CONFIG_VIDEO_SELECT is not set
    # CONFIG_MDA_CONSOLE is not set
    # CONFIG_FB is not set

    #
    # Sound
    #
    CONFIG_SOUND=m
    # CONFIG_SOUND_ES1370 is not set
    # CONFIG_SOUND_ES1371 is not set
    # CONFIG_SOUND_SONICVIBES is not set
    # CONFIG_SOUND_MSNDCLAS is not set
    # CONFIG_SOUND_MSNDPIN is not set
    CONFIG_SOUND_OSS=m
    # CONFIG_SOUND_PAS is not set
    CONFIG_SOUND_SB=m
    CONFIG_SOUND_ADLIB=m
    # CONFIG_SOUND_GUS is not set
    # CONFIG_SOUND_MPU401 is not set
    # CONFIG_SOUND_PSS is not set
    # CONFIG_SOUND_MSS is not set
    # CONFIG_SOUND_SSCAPE is not set
    # CONFIG_SOUND_TRIX is not set
    # CONFIG_SOUND_MAD16 is not set
    # CONFIG_SOUND_WAVEFRONT is not set
    # CONFIG_SOUND_CS4232 is not set
    # CONFIG_SOUND_MAUI is not set
    # CONFIG_SOUND_SGALAXY is not set
    # CONFIG_SOUND_OPL3SA1 is not set
    # CONFIG_SOUND_SOFTOSS is not set
    CONFIG_SOUND_YM3812=m
    # CONFIG_SOUND_VMIDI is not set
    # CONFIG_SOUND_UART6850 is not set

    #
    # Additional low level sound drivers
    #
    CONFIG_LOWLEVEL_SOUND=y
    # CONFIG_ACI_MIXER is not set
    CONFIG_AWE32_SYNTH=m
    # CONFIG_AEDSP16 is not set

    #
    # Kernel hacking
    #
    # CONFIG_MAGIC_SYSRQ is not set
    ----------------------------------------------------------------------

    Please CC replies to
    andy@ajsoft.demon.co.uk

    since I haven't the bandwidth to follow all kernel mailing list correspondence.


    TIA
    --
    Andy Jefferson


    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.rutgers.edu
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:45    [W:0.046 / U:88.528 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site