lkml.org 
[lkml]   [1998]   [Jan]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject[2.1.84] no IDE DMA (was [2.1.79] no IDE DMA)
On Wed, 14 Jan 1998, Gadi Oxman wrote:

> On Wed, 14 Jan 1998, B. James Phillippe wrote:
>
> > PCI devices found:
> > Bus 0, device 7, function 0:
> > ISA bridge: Intel 82371FB PIIX ISA (rev 2).
> > Medium devsel. Fast back-to-back capable. Master Capable. No bursts.
> > Bus 0, device 0, function 0:
> > Host bridge: Intel 82437 (rev 2).
> > Medium devsel. Master Capable. Latency=32.
>
> Looks similar to the Intel Advanced/ZP problem -- the IDE interface is
> not being found. I have appended two patches which attempt to work around
> the problem; is the IDE driver able to detect the PIIX with one of them?

Hello Gadi,

I've tried both patches and DMA still does not work on my system.
Again, my system is a Tyan Titan III with the above shown PCI IDE chipset.
This box has been running with DMA under all previous kernels (was it
2.1.76 it broke at, I think?) without a problem. I'm running 2.1.84 now
and still no DMA. When I try to set it with hdparm, it says "Operation not
permitted". And at boot time, when the kernel lists the hard drives in the
system, it doesn't say "DMA" like it used to.

Thanks,
-bp
--
B. James Phillippe <bryan@Terran.ORG>
Linux Software Engineer, WGT Inc.
http://w3.terran.org/~bryan


\
 
 \ /
  Last update: 2005-03-22 13:41    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site