[lkml]   [1997]   [Jun]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    Subjectanother pre-2.0.31 problem
    In article <5msanc$> you wrote:
    : > I wonder why the "stable" version of the kernel (2.0) has had almost as
    : > many patches as the "devel" (2.1) version, and it's still full of problems?
    : Full of ?
    : Have you got some we missed
    perhaps i got one ...

    : 2.0.pre31 + patches should be pretty much solid for everyone except for that
    : one memory allocation issue. Are you seeing otherwise ?
    aehm, i got a "nice" networking problem.
    i have two local ethernets (split for security) and
    dial up to my ISP via ISDN (HDLC, snycPPP).
    both networks and the isdn are connected to a
    masqerading router/firewall.
    386-dx-40, 8mb ram, 2x cheap-o-ne2000, 1x teles 16.3;

    everything works fine localy, and even the isdn pretends to work most times.
    i can irc around, use the WWW, use ftp, play quake ...
    all from a masqed host. but when i try to send more than
    a hand full of data (ftp-put-command, dcc-send, news-suck
    trying to post a BIG article, ...) the router panics away.
    > Kernel panic: skpush:under: <somewhere>:2
    > In swapper task - not syncing
    btw, this is 100% repro at least since
    kernel 2.0.27 ! ... (took some time to
    hunt the bug down ...)

    small ftp-puts are ok (5k or so is the limit).
    the panic-adress resolves to somewhere in the
    isdn_ppp_xmit-routine, and i discussed the prob
    with Karsten Keil (Master-of-HiSax) and
    Michael Hipp (Master-of-ipppd) but no solution so far.
    michael said that someone (in a higher net-layer)
    migth be messing around with the SKBs ...

    /me tends to accuse masq.
    i can ftp-put my kernel-image (standard-test)
    from the router, but not from a masqed host.

    uh, and i discovered another "effect" some days ago.
    i tried to get the latest unoff-kernel-patches from
    using "lynx" the router paniced.
    using netscape, it worked.
    again, this is 100% repro !

    i tried virtually everything with kernels from 2.0.27 to pre-2.0.31.
    compiled (and tested) dozens of kernels in the last few weeks ...

    i dont include megs-o-log and megs-o-config here.
    karsten and michael already got lots-o-info and did not
    find a solution for now. if anyone of you gurus is
    interested in the prob, i can mail some more infos directly. :)

    any ideas ?


    Hauke Johannknecht
    -> Hamburg / Germany <- -
    --> pgp-key via public-key-server and on request <--> use pgp ! <--

     \ /
      Last update: 2005-03-22 13:39    [W:0.021 / U:9.556 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site