lkml.org 
[lkml]   [1997]   [Nov]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectParport irq detection problem in 2.1.62.
    Hi,
    I have a irq detection problem with the parallel port driver in 2.1.62.
    It cannot detect my second (polling) parallel port correctly (parport1.)

    Here is the logging output:
    Nov 7 08:52:15 hafnium kernel: parport0: PC-style at 0x378 [SPP,ECPEPP,ECPPS2]
    Nov 7 08:52:15 hafnium kernel: parport1: PC-style at 0x278, irq 0, dma 0 [SPP]

    When lp is loaded it reports the printer at parport0 as polling and the
    one at parport1 as interrupt-driven. I cannot print to the one at
    parport1, but I get the message "Trying to free free IRQ0".

    The driver is compiled as a module and was loaded by kerneld with the
    following options in /etc/conf.modules:
    options parport_pc io=0x378,0x278


    I can print to both printers if I give these options in /etc/conf.modules:
    options parport_pc io=0x378,0x278 irq=-2,-2

    (-2 is the magic number for PARPORT_IRQ_NONE.)

    The logging output is now:
    Nov 7 08:52:15 hafnium kernel: parport0: PC-style at 0x378 [SPP,ECPEPP,ECPPS2]
    Nov 7 08:52:15 hafnium kernel: parport1: PC-style at 0x278, dma 0 [SPP]

    It now (correctly) reports both printers as polling.

    It seems that the irq auto detection returns 0 when it should return
    PARPORT_IRQ_NONE.

    The driver probably shouldn't report "dma 0" but it doesn't seem to have
    any effect.

    --
    Med venlig hilsen / Regards

    Niels Kristian Bech Jensen nkbj@image.dk
    http://www.image.dk/~nkbj/


    \
     
     \ /
      Last update: 2005-03-22 13:40    [W:0.022 / U:0.460 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site