lkml.org 
[lkml]   [1997]   [Jan]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: BUG: Apache/Stronghold and Linux 2.0.X
    DUPRE Christophe wrote:
    >
    > Many peoples have reported problems running Apache 1.1.1 (latest non-beta
    > version) and Stronghold 1.3.2 (latest non-beta version) under Linux 2.0.x.
    > I'm one of these persons, and I believe that Linux is the culprit. So I
    > experimented a bit, and here are my results. But first, the facts:
    >
    > Here's my primary server:
    > Pentium 133, with Intel 430FX
    > 64 Megs RAM
    > Adaptec 2940 with 1gig Hard drive and tape backup
    > NE2000 compatible network card
    > IDE CDROM
    > Linux 2.0.0
    >
    > And my development workstation:
    > PentiumPRO 200
    > 48 megs RAM
    > Adaptec 2940UW with 2 gigs Hard drive
    > Kingston network card (DEC 21041)
    > Linux 2.0.27
    >
    > That's the starting configuration. Both works perfectly with Stronghold
    > 1.3.2.
    >
    > Now, I wanted to upgrade the server to 2.0.27 to fix various security
    > problems (mostly the ping of death). After upgrading, stronghold gave
    > problems: The web browser would successfully pull the 4 first files for
    > each page then wait for a long time for the fifth then fail. My Netscape
    > is configured to open 4 simultaneous connections - I don't know if
    > there's a connection between those values as I haven't experimented.
    > So I decided to upgrade kernel by kernel to see where the problem arized.
    > I did not exactly try all the kernels between 2.0.0 and 2.0.27, but I did
    > a binary search, trying 2.0.0, then 2.0.14, then 2.0.20, then 2.0.24.
    > All of these worked, compiled with the same options.
    > Then 2.0.25 didn't work. So I applied manually all the diffs included in
    > patch-2.0.25 to see which one broke stronghold, and I found the one
    > included at the end of this message. Now since I'm no network guru, I
    > have no idea what to do now, except post this here...
    >
    > Please note the following :
    > - Stronghold works with linux-2.0.27 on my workstation which is not so
    > dissimilar to my server, except the processing power, so this MAY be a
    > kind of race condition.
    > - I have not tried 2.0.26
    > - both computers have the same compiler, libraries, etc...
    > - The workstation runs X11, not the server
    > - The problem shows up reliably, even just after bootup, with minimal load.
    >
    > I am willing to do some further testing if deemed appropriate by any
    > kernel guru.
    >
    > I hope this bug report is complete enough, please contact me if more info
    > is needed.

    I have been running Stronghold on a i486 and 2.0.26 without problem
    since 2.0.26 came out. This includes virtual servers and cgi's.

    andy

    \
     
     \ /
      Last update: 2005-03-22 13:38    [W:0.024 / U:89.768 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site