lkml.org 
[lkml]   [1996]   [Aug]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject29M physRAM free but swap used running crashme under 2.0.13
I have a P100 40M RAM, RedHat 3.0.3 upgraded to kernel 2.0.13, I was
running an hour of crashme-2.4 (couldn't get to sleep ;) and while
sifting through my mail folders I noticed a slowdown with activity
on the disk. To my surprise I was swapping. First time since I went
from 16 to 40M RAM 50 days ago. I did a ps aux and a free. Look.

USER PID %CPU %MEM SIZE RSS TTY STAT START TIME COMMAND
asuardi 138 0.0 0.0 1304 8 1 S 00:38 0:00 (tcsh)
asuardi 152 0.0 0.0 1208 0 1 SW 00:38 0:00 (startx)
asuardi 153 0.0 0.0 1876 12 1 S 00:38 0:00 (xinit)
asuardi 156 0.0 0.1 1208 44 1 S 00:38 0:00 sh
/home/asuardi/.xin
asuardi 157 0.0 1.0 2136 404 1 S 00:38 0:01 fvwm
asuardi 160 0.0 0.4 2028 184 1 S 00:38 0:00
/usr/lib/X11/fvwm/Goo
asuardi 161 0.0 0.4 1964 196 1 S 00:38 0:00
/usr/lib/X11/fvwm/Fvw
asuardi 164 0.0 0.8 3216 316 1 S 00:38 0:00 xbiff -bg
Grey20 -fg
asuardi 165 0.0 0.6 2164 272 1 S 00:38 0:00 xclock -bg
Grey20 -fg
asuardi 166 0.0 0.0 1296 8 p0 S 00:38 0:00 (tcsh)
asuardi 254 0.0 1.1 1288 464 p1 S 01:14 0:00 -csh
asuardi 266 0.1 0.3 868 144 p0 S 01:15 0:02 ./crashme
+2000 666 1
asuardi 1573 99.9 0.8 908 336 p0 R 01:40 0:08 ./crashme
+2000 1928
asuardi 1574 0.0 1.1 940 448 p1 R 01:40 0:00 ps aux
bin 85 0.0 0.0 912 0 ? SW 00:38 0:00 (portmap)
root 1 0.1 0.0 888 0 ? SW 00:37 0:04 (init)
root 2 0.0 0.0 0 0 ? SW 00:37 0:00 (kflushd)
root 3 0.0 0.0 0 0 ? SW< 00:37 0:01 (kswapd)
root 12 0.0 0.1 864 48 ? S 00:38 0:00 /sbin/kerneld
root 54 0.0 0.3 920 156 ? S 00:38 0:00 syslogd
root 63 0.0 0.0 888 0 ? SW 00:38 0:00 (klogd)
root 74 0.0 0.2 896 80 ? S 00:38 0:00 crond
root 97 0.0 0.0 912 0 ? SW 00:38 0:00 (inetd)
root 113 0.0 0.8 1292 332 ? S 00:38 0:00 sendmail:
accepting c
root 125 0.0 0.0 908 0 ? SW 00:38 0:00 (lpd)
root 139 0.0 0.0 924 0 2 SW 00:38 0:00 (getty)
root 140 0.0 0.0 924 0 3 SW 00:38 0:00 (getty)
root 141 0.0 0.0 924 0 4 SW 00:38 0:00 (getty)
root 142 0.0 0.0 924 0 5 SW 00:38 0:00 (getty)
root 143 0.0 0.0 924 0 6 SW 00:38 0:00 (getty)
root 145 0.0 0.1 860 48 ? S 00:38 0:00 update
(bdflush)
root 154 3.4 4.2 5352 1676 ? S 00:38 2:07 X :0
root 158 0.2 1.2 2388 480 1 S 00:38 0:09 xterm
root 253 0.0 1.8 2388 720 1 S 01:14 0:00 xterm

total used free shared buffers cached
Mem: 39332 10068 29264 3840 504 5600
-/+ buffers: 3964 35368
Swap: 35276 5876 29400

Crashme ended, I even quit Netscape (3.0b7) and exited X, but still
I had little less than 2M swap used with over 30M free RAM.

Is this normal ? I don't remember having ever seen swap_used != 0.
Feel free to tell me I'm a dummy, I'm here to learn :)

--alessandro

\
 
 \ /
  Last update: 2005-03-22 13:37    [from the cache]
©2003-2011 Jasper Spaans