lkml.org 
[lkml]   [1996]   [Jul]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: SB16 Sound driver problem
On Tue, 16 Jul 1996, Rob Riggs wrote:

> I am having big problems with the SB16 sound driver for the
> latest kernels. I'm not sure when this started. Under kernel
> 2.0.4, loading sound.o via kerneld works *once* only. After
> that it loads, but puts:
>
> sb: Interrupt test on IRQ10 failed - device disabled
>
> in the syslog. I then get "device not availible" messages when
> trying to use any of the sound utils. On later kernels (2.0.6
> and 2.0.7) I get a complete system hang the second time
> kerneld tries to load sound.o. (I've done this by hand with
> insmod as well). I did not try kernel 2.0.5.
Don't try to use kerneld if you have SB16 version 4.5. For some reason
this particular firmware version causes troubles when _warm_ loading the
sound driver while there are no problems with any other SB version.

This problem may be related with interrupt test feature added in Linux
2.0.1. It's possible to bypass the test by adding

#define NO_SB_IRQ_TEST

to the beginning of linux/drivers/sound/sb_commob.c. However nobody has
reported that this change helps. Somebody claimed that leaving MIDI
support out from configuration could help too.

Best regards,

Hannu
-----------------------------
Hannu Savolainen (hannu@voxware.pp.fi, hannu@4front-tech.com)
http://personal.eunet.fi/pp/voxware/hannu.html (my home page)
http://www.4Front-Tech.com/uss.html (UNIX Sound System (USS))
http://personal.eunet.fi/pp/voxware (USS Lite/TASD/VoxWare)


\
 
 \ /
  Last update: 2005-03-22 13:38    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site