lkml.org 
[lkml]   [1996]   [Apr]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: Modules. What's the deal?
Date
	You upgraded binutils recently, you should revert to a non beta
version.

That will fix your problem.

You will need to rebuild the modules afterwards.

_ jared

James L. McGill spewed:
> What's going on here?
>
> ikyr:/lib/modules/1.3.85/fs# insmod fat.o
> gcc2_compiled. undefined
> gcc2_compiled. undefined
> gcc2_compiled. undefined
> cache undefined
> fat_cache undefined
> gcc2_compiled. undefined
> gcc2_compiled. undefined
> gcc2_compiled. undefined
> gcc2_compiled. undefined
> gcc2_compiled. undefined
> gcc2_compiled. undefined
> Failed to load module! The symbols from kernel 1.3.85 don't match 1.3.85
>
> This is my Kernel config:
>
> #
> # Loadable module support
> #
> CONFIG_MODULES=y
> # CONFIG_MODVERSIONS is not set (same effect if it IS set).
> # CONFIG_KERNELD is not set
>
>
> I have gcc-2.7.2, libc-5.3.9, make-3.74, binutils-2.6.0.12, and modules-1.3.57,
> and generally have no system problems, and no problems compiling and installing
> the kernel or the modules.
>
> I have read everything I can find about modules and am now at the
> pont of asking the kernel list users for help. Thanks for any help!
>
>
> --
> g-r-a-t-e-f-u-l-l-y---[ email:<fishbowl@conservatory.com> ]---l-i-v-i-n-g
> d-e-a-d-i-c-a-t-e-d---[ http://www.conservatory.com/~fishbowl ]-----l-i-g-h-t
>
>



\
 
 \ /
  Last update: 2005-03-22 13:36    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site