lkml.org 
[lkml]   [1996]   [Mar]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    SubjectRe: Diald doesn't work with 1.3.72
    Date
    Eric Schenk writes:

    > Kevin Buettner <kev@primenet.com> writes:
    > >I rebuilt 1.3.72 and disabled network firewalling, IP forwarding,
    > >IP firewalling, and IP masquerading. (All of these were enabled in
    > >the previous version of 1.3.72 that I reported on.)
    >
    > I've since plugged in the firewall stuff you reported using and
    > found similar problems. I'm still working on this, but I think
    > I understand part of what is going on.
    >
    > >I played around some more with diald-0.12 in 1.3.70. I had first tried
    > >it back in the days (not that long ago) when it would hang the kernel
    > >on disconnecting. I had heard that it no longer does this (which is
    > >true for me). But it still doesn't work properly: diald-0.12 will connect
    > >properly and I get connectivity, but when I watch what is happening with
    > >dctrl, after the connection is made it doesn't seem to see any of the
    > >packets going through and eventually the connection is dropped.
    >
    > I've been able to reproduce this here now.
    >
    > >Also, I have not been succesful at getting the "reroute" option to work. I
    > >expected the default route (as displayed by "netstat -r") to change to the
    > >ppp0 device instead of going to sl0, but this does not happen. Perhaps I
    > >misunderstand the intent of the reroute option?
    >
    > Ah! A clue. You understood what it was suppose to do correctly.
    > The fact that it is not working is a bug. I've fixed it in
    > my sources. I'll be releasing this tomorrow.
    >
    > In the mean time, what is happening is that if you don't specify
    > your exact remote address to diald in the remote option, then
    > the rerouting breaks.
    >
    > There is another bug I need to track down yet. It seems that
    > if you do not use the "reroute" option, then in 1.3.7[0-3] kernels
    > the kernel throws away all the traffic that arrives at the interface.
    > I haven't had time to determine exactly why yet.
    >
    > These bugs together hose anyone who is using dynamic PPP or SLIP,
    > and anyone who sets things like "remote 127.0.0.3" in their diald options.
    > If you must have things working before I can figure out the necessary
    > fixes for the last bug, make sure that you use the "reroute" option,
    > and set your "remote" address correctly!

    I can't set my "remote" address correctly because it is dynamic. OTOH,
    my local address is static. Should I still specify the dynamic option
    or not?

    I'm glad that you've got most of it figured out. I'm eagerly awaiting
    your next release.

    Regards,

    Kevin


    \
     
     \ /
      Last update: 2005-03-22 13:36    [W:0.020 / U:2.176 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site