[lkml]   [1996]   [Nov]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: Linux doing "cooperative multitasking"? (fwd)

    > > Hallo,
    > >
    > > I use Netscape Version 3.01 on Linux 2.0.25 and XFree 86-3.1.2.F. (Well now
    > > it is Xfree 86-3.2)
    > > At present I preload and, but I had the problems
    > > with and too. Here my problem ( or better
    > > observation).
    > >
    > > I start netscape on an rxvt-Term. I forgot to send it in the Background by
    > > not giving "&" at the end of the command line. So I hit "^Z" on the terminal I
    > > started netscape. Nothing happens for a long time or at all.
    > After you hit ^Z did you put the process in the background with "bg"?

    This is an odd buglet. Here's exactly what happens:

    Start netscape as a foreground process
    While the focus is in the window netscape was started from, hit Ctrl-Z
    -- Nothing will appear to happen

    Change the input focus to the Netscape window
    -- 'Suspended' will appear in the xterm/rxvt (from the previous Ctrl-Z)

    Now fg/bg/etc. commands will work.

    Not necessarily even annoying, but kind of odd. I haven't bothered to
    track down why it happens.

    "Honestly, it's like shooting | Bob Glamm H: +1 612 6239437 W: +1 612 6268981
    fish in a barrel. Twice. With | URL:
    an elephant gun. At point +-----------------------------------------------
    blank range. In the head." -- from the BOFH files, part 6

     \ /
      Last update: 2005-03-22 13:38    [W:0.019 / U:7.044 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site