[lkml]   [1996]   [Oct]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectNaming conflict in sound drivers
    I have been attempting to patch the version 2.1.5 sound driver sources
    to allow compilation. I have succeeded with the "get_user" conversions
    (at least those used by my configuration), but I found a pre-existing
    usage of "copy_from_user" in audio.c at line 246 of my patched file.
    This line gives me: macro `copy_from_user' used with too many (6) args.

    The pre-existing "copy_from_user" is declared in "dev_table.h", included
    from "sound_config.h".

    Perhaps this local function should be renamed i.e. audio_copy_from_user??

    One file I have not yet tackled is dmasound.c, which uses "get_user" inside
    a macro definition at line 148: #define IOCTL_IN(arg) get_user((int *)

    My limited C programming skills are puzzled also by:
    dmasound.c:736: *p++ = get_user(userPtr++) ^ 0x80;
    My configuration (Media Vision sound card with Sanyo CD) does not use this
    file, but I am always interested in learning 8^)

    Thanks to all who have made this educational experience possible.

    Darrell A Escola

     \ /
      Last update: 2005-03-22 13:38    [W:0.017 / U:0.424 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site