lkml.org 
[lkml]   [2024]   [May]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRE: [PATCH v3] x86/cpu: Fix x86_match_cpu() to match just X86_VENDOR_INTEL
Date
> >     for (m = match;
> > - m->vendor | m->family | m->model | m->steppings | m->feature;
> > + m->vendor | m->family | m->model | m->steppings | m->feature | m->flags;
>
> I think this should not do anything implicit even if it is correct but
> should explicitly check
>
> if (!(m->flags & X86_CPU_ID_FLAG_VENDOR_VALID))
> continue;
>
> I don't have a clear idea how exactly yet - I need to play with it.
>
> Maybe this stupid flow in the loop should be finally fixed into
> something more readable and sensible...

What if the bit in flags was named " X86_CPU_ID_FLAG_ENTRY_VALID"

Then the loop in x86_match_cpu() could just be:

for (m = match; m->flags & X86_CPU_ID_FLAG_ENTRY_VALID; m++) {

...
}

-Tony
\
 
 \ /
  Last update: 2024-05-27 18:30    [W:0.075 / U:0.768 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site